PPPoEサーバをCisco1812で構築してみた

Pocket

今回はCisco1812を使用してPPPoEサーバを構築したいと思います。

Cisco1812はルータポートが2つしかないため、スイッチのポートにVLANを割り当てて使用します。

PPPoEのクライアントはRTX1200、SSG5、Fortigate60Dを考えてます。
また今回はPPPoEサーバのみのコンフィグとなります。
PPPoEクライアントは次回記載したいと思います。

項目RTX1200—用Fortigate60D—用SSG5用
PPPoE接続用
ユーザ名
RTX1200@testFortigate60D@testSSG5@test
PPPoE接続用
パスワード
RTX1200@testFortigate60D@testSSG5@test
ƒインタフェースへ割り当てるIPアドレス192.168.101.254192.168.102.254192.168.103.254
VLAN102030
使用するインタフェースFastEthernet2FastEthernet3FastEthernet4

●PPPoEサーバコンフィグ(Cisco1812)

vlan database
 vlan 10
 vlan 20
 vlan 30

exit

conf t

hostname PPPoE-SV

!※ここのユーザ名、PWはクライアントと合わせば何でも可
username RTX1200@test password 0 RTX1200@test
username Fortigate60D@test password 0 Fortigate60D@test
username SSG5@test password 0 SSG5@test

bba-group pppoe PPPOE-GROUP1
  virtual-template 1

 bba-group pppoe PPPOE-GROUP2
  virtual-template 2

bba-group pppoe PPPOE-GROUP3
  virtual-template 3

interface Loopback1
 ip address 192.168.1.1 255.255.255.255

interface Loopback2 
 ip address 192.168.2.1 255.255.255.255

interface FastEthernet2
 switchport access vlan 10

interface FastEthernet3  
  switchport access vlan 20

interface FastEthernet4  
  switchport access vlan 30

interface Virtual-Template1 
 mtu 1454
 ip unnumbered Loopback1
 peer default ip address pool POOL1
 ppp authentication chap

interface Virtual-Template2  
 mtu 1454
 ip unnumbered Loopback2
 peer default ip address pool POOL2
 ppp authentication chap

interface Virtual-Template3  
  mtu 1454
  ip unnumbered vlan30
  peer default ip address pool POOL3
 ppp authentication chap

interface Vlan10   
 no ip address
 pppoe enable group PPPOE-GROUP1

interface Vlan20   
 no ip address
 pppoe enable group PPPOE-GROUP2

interface Vlan30   
  ip address 192.168.3.1 255.255.255.252
  pppoe enable group PPPOE-GROUP3

!※RTX1200のインタフェースへ振り出したいアドレスを入力
 ip local pool POOL1 192.168.101.254 

!※FG60Dのインタフェースへ振り出したいアドレスを入力
 ip local pool POOL2 192.168.102.254 

!※SSG5のインタフェースへ振り出したいアドレスを入力
 ip local pool POOL3 192.168.103.254 

end

これでPPPoEサーバ側の設定は完了です。

Pocket

ネットワークが不安定になる

Pocket

ネットワーク切り替え当日に起こった問題です。

ネットワークの切り替えを行い、 複数拠点からpingによる通信確認をしていた時です。
何故かpingが不定期で落ちると言うネットワークが不安定な現象が発生しました。

原因を調べていくと、ルータと L2SWのSPEEDとDUPLEXが合ってないことが分かりました。
設定は以下のようになってました。

グラフィックス1
どうやらルータが全二重通信、L2SWが半二重通信となっていたことにより、ネットワークが不安定になっていたようです。

“ネットワークが不安定になる” の続きを読む

Pocket